1

For a while now I have been unable to use DD Updater because of this error:

Warning!
Our test AJAX request failed! We sent an AJAX request to but the response was   invalid.

I don't recall if the error started when I upgraded the module or when I moved to a different host, regardless I'm using EE2.5.5 and I have upgraded to the latest version of updater today (3.2.9) with no success. I tried changing several settings and nothing changed, can anyone point me in the right direction? The ajax response is blank btw.

Thank you.

  • What is the exact error message/code you are getting? That might explain what is happening. – Manuel Payano Nov 28 '13 at 12:20
1

First of all, check if

  • URL to the root directory of your site
  • URL to your 'themes' folder

is setup correct in EE > Admin > General Configuration

If you will not found any error inside this settings, you need to open chrome inspector and check what exactly happens. On tab Network you will able see the ajax request (url & headers) + results. Possible something wrong with your .htaccess and you have multi redirection as example.

For example it is can happen if your CP is on domains with www., but request is going to domain w/o www..

  • Thanks, I checked the headers and it was all working as it should, then I realized that I hadn't tried deleting all updater files and re-uploading, I did that and it's working fine now. – Isabel Nov 28 '13 at 14:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.