0

I've installed Minimee. It doesn't seem to be combining CSS and JS files, despite them being wrapped in {exp:minimee:css} and {exp:minimee:js} respectively. Minimee is installed and "Combine Assets" are checked for CSS and JS (as well as "Minify").

When I view the rendered template, I still see the individual files itemized in the mark up. Basically, they weren't combined. They weren't minimized, either. NOTE: CSS and JS files are in templates.

It seems that when I check the minify HTML checkbox that it does affect the mark up a bit (though I thought it would minify it to the point that the HTML becomes a single line -- unless there are <pre> or <code> tags, I suppose).

Anyway, Minimee doesn't seem to be doing its thing. So, I am trying to debug it by turning on Template Debugging. I have set it in CPanel. However, I don't see anything on the rendered page that looks like template debugging. I am logged in as a Super Admin.

Any ideas what might be wrong with Minimee or Template Debugging?

UPDATE 1:

I created the cache folder in the wrong place (was confused since I am using MSM). It's been fixed now. Minimee is now creating the combined/minified CSS and JS and in the cache folder. It seems to also properly reference it from within the templates. However, it seems like what is being retrieved is the home page's HTML instead of the actual contents of the file in the cache folder. Still looking into this.

UPDATE 2:

Seems that there might be some sort of server issue. When I go to www.domain.com/cache/, I see the combined/minified JS and CSS files. However, when I click on them, I get a 404 error.

  • Not sure why you are not seeing template debugging though, have you created a cache folder and url for Minimee? – Natetronn Dec 17 '12 at 1:24
  • I created a "cache" folder in my root. 777. No files appear in there. I have leave cache folder and url blank. – ExpressionEngineNewbie Dec 17 '12 at 1:33
  • I use - github.com/bunchjesse/AutoMin Great because it works with .less as well! – LMBRJCK Dec 17 '12 at 17:09
1

Is it possible your template is cached and so not rendering the correct version?


Template debugging will appear at the bottom of the page after enabling it in the control panel. If you don't see it, try inspecting the page to see if your reset CSS is somehow hiding it. Also, try setting up a blank test template, you should see the output on that page. Check out this SE question, perhaps you are hitting the same issue.

The debugging output will look like this:

enter image description here


Minimee, if I remember correctly, will create a new file name altogether. It will be obvious when it's working.

If you are using {path=} to create the JS or CSS urls, remove that and try just the path from root... eg: /global/js.

Try moving your JS/CSS to actual files to see if it combines them in that format.

If still not working, try the code in a new blank test template.

Another thing to try is to reupload all the addon files anew. Perhaps something was missed or corrupted?

| improve this answer | |
  • I disabled CSS using Web Dev Toolbar. Template Debugging is not there. I removed {path=}, that didn't minify/combine anything. I created a template that only has <h1>Hello World</h1>; it did not display template debugging/output profiler despite them being enabled in CPanel. Trying the other things you suggested. – ExpressionEngineNewbie Dec 17 '12 at 2:04
  • Are you seeing template debugging at the bottom of your control panel pages? – Anna_MediaGirl Dec 17 '12 at 6:33
2

I seem to remember somewhere that minimee wont work correctly if the css isn't valid. Can you check and see if the css validates? It might be that the minimee wont fire without it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.