3

Our site was working just fine yesterday. And when we go to it today it is blank on the homepage and CP.

I turned debugging on in index.php and admin.php and it returned:

Warning: require(/var/www/vhosts/domain.com.au/httpdocs/system-46cjg2378sW/codeigniter/system/core/Exceptions.php): failed to open stream: 
Too many open files in /var/www/vhosts/domain.com.au/httpdocs/system-46cjg2378sW/codeigniter/system/core/Common.php on line 137 Fatal error: require(): 
Failed opening required '/var/www/vhosts/domain.com.au/httpdocs/system-46cjg2378sW/codeigniter/system/core/Exceptions.php' (include_path='.:') in /var/www/vhosts/domain.com.au/httpdocs/system-46cjg2378sW/codeigniter/system/core/Common.php on line 137

What on earth could have happened overnight? We haven't made any updates.

2

As you all suspected it was an ISP issue. They took our server offline for a few hours last night and have resolved the issue. I have pushed them twice to provide a detailed answer about the issue in a hope to post it here in order to help others that might experience this problem.

This is the best I could get out of them:

I've checked the details with our senior technicians, and as per their update, the issue has been resolved now. As updated in the network status page, we had experienced an intermittent connectivity to some websites on linux shared hosting. As it is a shared server, I'm sorry to say that, we are unable to provide you more details because of security reasons. I can confirm that the issue has now fully resolved.

Very non-specific, sorry.

Thank you to everyone that took the time to make suggestions about what we could do to try an solve it ourselves.

  • You should accept an answer, yours or which ever you feel got you closest to a solution. – nonprofit_tech Dec 19 '12 at 3:46
1

This isn't an answer to why it happened suddenly or what it causing it to open so many files, but if you have shell access on tour server, run ulimit -a and look for your open files limit. That is the number that you are running over that is causing your issue. If this number seems quite low, perhaps getting your host to raise it will be your solution.

I have seen similar errors reported with big sets of playa matrix fields. Do you have any monster channel field groups or anything like that that might cause this?

  • no shell access. we have a matrix field per entry (online store) that has 3 rows to show different images. about 200 products in total. not sure that would be considered 'monster'? – Mike Dexter Dec 17 '12 at 7:47
  • You probably have a control panel that allows you to see various settings about your host. The open files limit may or may not be there, I would just point out to your ISP that you are seeing this issue and ask them what the open files limit is, and whether it is possible to raise it. The issue the debugger is raising is that too many images are being opened at one time. If you really didn't change anything at all it is strange to start seeing this unless the ISP changed something. – UltraBob Dec 18 '12 at 0:30
0

Check to see if your ISP made any updates. It's possible your version of PHP was changed overnight.

  • I just uploaded a phpinfo() file and it says it's running PHP Version 5.3.3 – Mike Dexter Dec 17 '12 at 6:13
  • Was that the version of PHP it was running yesterday? Also, what version of EE are you running? – nonprofit_tech Dec 17 '12 at 6:15
  • Not sure what version of PHP was running yesterday, sorry. EE is 2.5.3 – Mike Dexter Dec 17 '12 at 6:16
  • Based on the error above, it seems as if a required file is no longer being opened or included in the CodeIgniter component of EE. Though, EE 2.5.3 should run perfectly fine with PHP 5.3.3. I've seen older versions of EE choke on a PHP upgrade, but frequently an update will work. Did you speak with your ISP regarding server changes? – nonprofit_tech Dec 17 '12 at 6:25
  • Also, this response has some great PHP troubleshooting information: expressionengine.stackexchange.com/questions/98/… though, it seems that you've already turned debugging on. – nonprofit_tech Dec 17 '12 at 6:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.