4

I have a few sites that upload a lot of files. My problem is, when someone uses the file upload the files getting uploaded are not owned by anyone at the server level.

rw-r--r-- 1 nobody nobody

Because these files are not owned by anyone, they are not recorded as part of that user's storage space on their hosting account.

Does anyone have any ideas how to get the user to own these files when they are uploaded?

I should also note that the sites in question are EE1 sites using nGen File Field as the file upload. I am guessing it is a bug in nGen File Field?

0
2

This is a PHP/apache config issue rather than an EE issue per se. I've seen it before, mostly on cPanel boxes. What kind of environment are you running on the server/do you have full control of the server config?

By default on some older installs that use DSO (mod_php) as the PHP handler, php runs as nobody (the apache user), resulting in nobody owning the files uploaded via PHP.

As it sounds to me as if php is running via mod_php from the above, would it be an option for you to use FastCGI (aka: mod_fastcgid) instead?

If you're running cPanel/WHM, changing the PHP handlers is very easy to do and only takes seconds. Log into WHM and navigate to: Main >> Service Configuration > Configure PHP and SuExec

Then just select your PHP handler choice from the drop-down menu. Then hit “Save New Configuration”. If you don't see your desired choice in the drop-down menu, it may need to be compiled on the server first. Run an “Easy Apache” to compile it.

There's a good discussion of the different PHP handlers and their pros & cons here.

5
  • Yes it is a cpanel/WHM setup I will try out your suggestions. It is only the nGen file upload that does this. the File uploads in EE2 do not seem to do this. Dec 17 '12 at 18:10
  • my choices are suphp, dso, or cgi... I do not see FASTCGI as an option. It is currently running in dso Dec 17 '12 at 18:13
  • 1
    It's probably a fairly old box then. suphp will effectively do the same thing, but it's pretty lousy for performance and not actively maintained (AFAIK), so may not be the best choice. Now that you've flagged this as an EE1/nGen file issue I will have a poke in the source to see if there's a fix/hack you could use, but nothing springs immediately to mind.
    – Tom Davies
    Dec 17 '12 at 18:34
  • I have been advised against using FastCGI due to the large memory footprint that will give me memory issues in the long run. The server is fairly new running CENTOS 6.3 i686 WHM 11.34.0 (build 11) Dec 17 '12 at 18:55
  • 1
    My experience has actually been the reverse (reduced memory usage but somewhat increased CPU) but YMMV of course. Often when people complain about poor FastCGI performance they're using mod_fcgid rather than mod_fastcgi (two different apache modules). You might posibly want to check out PHP-FPM which can help with FastCGI performance, though I don't know about integrating it with WHM/cPanel/EasyApache
    – Tom Davies
    Dec 17 '12 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.