3

I'm trying to deploy a new version of an EE site which has been upgraded to 2.7.2.

Rather than just overwrite the existing system folder, I'm uploading the new one alongside it (with a different name) but when I update $system_path in admin.php to point to the folder, I get Your system folder path does not appear to be set correctly. If I change it back again, the CP login page loads.

The path/name is definitely correct, I'm just swapping out the name of one for the other and they're both at the same level in the directory structure.

What else could be causing EE to not recognise the new system folder (server is running Windows if that helps)?

4
  • Have you also updated the system path in index.php? – foamcow Dec 11 '13 at 8:56
  • I hadn't because I've done this before on other sites (admittedly running Linux servers) and it's been fine. That way you can effectively have two different versions of EE running side by side so you can verify everything in the CP of the new install is OK while the front-end is still displaying the old site. But I've just tried updating it and get the same result. – Tyssen Dec 11 '13 at 12:26
  • config/config.php settings? – Stephen Callender Dec 11 '13 at 12:49
  • No, that's fine too. Identical to the system folder that is working apart from the version number. – Tyssen Dec 11 '13 at 21:05
1

This is more of a comment, but my rep is too low to comment.

Could it be a DB value? Any special characters in the second system folder name?

3
  • No, I don't think so. I just uploaded this site to a server running Linux this morning and it's all running flawlessly. So I'm thinking at this point, that the problem is specifically due to Windows. – Tyssen Dec 12 '13 at 1:23
  • Doesn't windows do their directory seperators as backslashes? Could it be that? – Brian Whitton Dec 12 '13 at 13:37
  • Yeah it does but the thing is the old CP works with ./old_system_folder but not with ./new_system_folder – Tyssen Dec 12 '13 at 21:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.