3

We have an existing site running on EE 1.6.8.

We decided to start afresh, clean new site so we have an install of v2.7.1 running.

We’ve built the site, finished the templates and are starting to look at running imports on any old content we want from the EE 1.6.8 site.

To achieve this we’re using Solspace’s Importer and have XML feeds for the old data.

The problem is some characters are outputting odd characters such as

Harrison’s

If we check the old database table the data looks fine:

Data ok

Where as the XML doesn't:

Wrong characters

We also have an issue where some entries that have been imported end up showing some strange characters in the new templates. An example of this can be seen here:

odd characters

Oddly the XML and entry appear ok for this:

XML ok

Entry OK

The old DB 'was' Latin1 but has been changed to UTF8 and that the new DB is UTF8 and the page template (RE 2nd problem) are UTF8 also as are the XML files.

What have we missed?

  • Post the code that is creating the XML please. – Anna_MediaGirl Jan 2 '14 at 20:53
  • I always avoid using any quotes in the title field and that may be why the Importer module is converting them. Usually I create a separate custom field called something like "Display Title" and use that on web pages along with any quotes it may need. Even though you've converted the database to UTF8 it seems likely that the data itself is still stored as Latin1. Your xml feeds could possibly be setup to convert the problem characters into standard ascii before importing but I don't know how you're coding your xml feeds. – Bob Foster Jan 2 '14 at 23:28
1

At a quick guess, I'd try the following (backup and do it all on local ideally)

  1. Change the formatting on those original fields from xhtml to 'none'.
  2. On your target install, also set the field formatting from xhtml to 'none'.
  3. After your import, update the fields to be xhtml formatted.

It's not going to help your titles though, titles are put through a typography filter you have no control over. Maybe use the query module to access title data when generating your xml...

Hopefully this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.