0

Can view channel entries authored by others Yes
Can delete their own channel entries Yes
Can edit entries authored by others Yes
Can delete channel entries authored by others Yes

All of these are set to Yes, but when I log in as an Editor and update an entry and click Submit, it gives me a "You are not authorized to perform this action" error in the control panel in the Options tab under Author. I do have the author selector hidden using publish layouts. Any ideas?

EE 2.6.1

1

Turns out this was a bug in the EE version I was using. The patch worked... https://support.ellislab.com/bugs/detail/19382

Thanks for looking into this for me Derek!

| improve this answer | |
0

My best guess is that Can change the author name when posting channel entries is set to No, and the author of the entry you're editing (or their member group - there are settings for both levels of granularity) is not set to Include Members in PUBLISH page multi-author list.

So when you got to save the entry, the Author menu defaults to another member (since the original author is not present in the menu), and you get the error because you're not allowed to change the author.

| improve this answer | |
  • Derek, "Can change the author name when posting channel entries" is set to NO. I also made sure "Include members in PUBLISH page multi-author list" is checked for both the member group and all members. Still get the same error. I'm wondering if this is a bug in EE or something. – Mike Lohrman Jan 2 '14 at 15:50
  • When logged-in as an Editor and getting this error on save, does the member selected in the Author field when you load the entry edit screen match what you see the entry's listing in the control panel? – Derek Hogue Jan 2 '14 at 15:59
  • The Author dropdown shows "Jeff" as he is the author of the entry. When I log in as "Bob" and try to re-save the entry, it throws the error and displays "Jeff" in the dropdown. – Mike Lohrman Jan 2 '14 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.