I am using: EE 2.7.2, Low Variables 2.4.0, WYGWAM 3.2.2

I have a WYGWAM field as a Low Variable, and within it, I am setting up some page links. When I create a link, under "Link Type" I chose "Site Page" and select the page on my site. However, when I output that variable on my homepage, the links are broken, and look like href="{page_38}". For some reason the page url isn't getting parsed. This "Site Page" method works fine for links in my channel entries.

Any idea how to get around this? For now, I just switched to specifying the URL manually, rather than selecting the site page. Thanks!


  • If it helps, my variable is set for early parsing and to save as a file. It is included directly within my index template. I tried turning off early parsing and that doesn't change anything. Commented Dec 28, 2013 at 20:09

2 Answers 2


For any variable that needs extra processing, like the Wygwam variable type, use the tag syntax rather than the variable syntax:

{exp:low_variables:single var="my_wygwam_var"}

Note that having early parsing on or off is irrelevant for the tag syntax, so you can leave it off.

  • I'm having the same issue on Low Variables 3.0.4 / Assets 3.0.0 / Wygwam 4.0.7 / EE 3.5.2. I tried both the tag syntax and the variable syntax. Happens regardless of what the wygwam file browser setting. Thoughts?
    – frshjb373
    Commented Mar 17, 2017 at 16:05
  • I am also having trouble with this. Using the tag syntax on EE3 3.5.1 with Wygwam 4.0.6 / Structure 4.0.0. Any solutions? My code (multi-language site) is: {exp:low_variables:single var="footer_block3_content_{segment_1}"} Commented Apr 6, 2017 at 10:06
  • 1
    If you're having trouble with the output of the Wygwam var, and you're using the above syntax, be sure to ask Wygwam's dev about it. LV just acts as a middle man, passing through the data that Wygwam handles.
    – Low
    Commented Apr 7, 2017 at 10:55

This has been fixed in Wygwam version 4.0.8!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.