2

I've just finished updating my EE installation from 2.6.1 to 2.7.3 but now that the update is complete I cannot log in. I can access the login page but when I enter my credentials it tries to load http://mysite.com/admin.php?S=0&D=cp&C=login&M=authenticate but it just hangs there forever.

Some things I have tried based on similar issues I found on the EE forum:

  • Tried using a different browser
  • Tried clearing browser cache and deleting EE cache folder
  • Tried adding $config[‘admin_session_type’] = “c” to config.php
  • Tried adding $assign_to_config[‘cookie_prefix’] = “site_name” to index.php and admin.php
  • Tried enabling debug mode in index.php and admin.php(did not get any errors when trying to load the Admin CP but when I try to load the homepage I am getting the following error:

    Fatal error: Class PT_Fieldtype contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (EE_Fieldtype::display_field) in \system_EE\expressionengine\third_party\pt_field_pack\pt_fieldtype.php on line 148
    

Any ideas? Thanks in advance!

3

The error message is pointing to an issue with Pixel and Tonic's Field Pack; you should attempt to upgrade it.

These "white screens of death" errors with the control panel after updating are frequently caused by an issue with an add-on; you temporarily disable them by adding $config['allow_extensions'] = "n"; to your config.php.

7
  • Thanks for the quick response! Apparently FieldPack replaced several other extensions and is now an all-in-one type deal. I deleted the old extensions and uploaded the new one via the link you posted as well as adding the line to disable add-ons to my config file. I am still having the same issue with admin.php but now on index.php I am getting this error since I deleted the old PT extensions: Unable to load requested field type file: ft.pt_dropdown.php. Confirm the fieldtype file is located in the expressionengine/third_party/ directory
    – APAD1
    Jan 2 '14 at 20:28
  • 2
    Detailed update instructions are here: docs.pixelandtonic.com/fieldpack/installation.html If that's not helpful, consider reaching out to P&T's support via twitter or email. Jan 2 '14 at 20:32
  • 1
    I love this answer (manually disabling extensions), as it coincides with a conversation my coworkers and I were having this morning about needing a "Safe Mode" login option for EE, wherein add-ons are disabled. We've run into numerous login issues with 2.7.3 that are all related to redirecting add-ons (see my answer below). Jan 2 '14 at 20:39
  • 1
    Alright, that worked. Once I was back on 2.6.1 I updated to FieldPack 2.1.1 and removed the older versions of the FieldPack extensions. Then I updated back to 2.7.3 and everything is working fine now. Thanks again for getting me pointed in the right direction Nick!
    – APAD1
    Jan 2 '14 at 21:15
  • 1
    Happy to help; happy new year! Jan 2 '14 at 22:14
2

Another potential fix is to add the following config overrides:

$config['require_ip_for_login']     = 'n';
$config['require_ip_for_posting']   = 'n';

My team has had luck with that when dealing with add-ons that offer the option to redirect on login (Structure and Republic Analytics in our experience).

1
  • Thanks for the suggestion Mark, I will give this a shot if my current course of action does not work.
    – APAD1
    Jan 2 '14 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.