0

I apologize for the vagueness of the question, but was looking for tips to debug more than a solution. I am using EE 2.7.2. I have a channel called products and a channel called resources. Within products there are two relationship fields (built-in relationship fields, not using an add on for it), one relating other products and another relating resources. Everything works as planned, but on multiple occasions (three times now) one of the relationship fields gets cleared for some of the product entries.

For example, Product A is related to Products B and C and Resources A, B, and C. It will all work then while reviewing the site (usually a week or so later) Product A will only be related to Resources A, B, and C and not related to any Products, as if they had been cleared.

Again I apologize for a lack of details but am totally stumped and not even sure where to start or what details to include? I have been grabbing a back up of the exp_relationships table each time it happens (before and after re-entering the relationships) and it appears that those rows are just getting removed for one of the relationship fields (it was the resource relationship twice and the product relationship once). There doesn't seem to be any action that triggers this or even a set timeframe, so I have very little to go on. One thing to note is that there is a channel form tag for another channel that also has a relationship field for Products. I tested this out thoroughly and it didn't seem to trigger the problem. I was hoping maybe someone else had experienced this or has some ideas of what to look for? Thanks!

4
  • Could it be related to this bug? It's marked as fixed in 2.7.2, but maybe not. – Derek Hogue Jan 3 '14 at 19:22
  • This doesn't appear to be the issue since both limits were set to 100 and wasn't changed and neither Products or Resources have more than 100 entries. But it is at least something to look into (the limit stuff). Thanks! – 2bsharpdev Jan 3 '14 at 19:40
  • Any other users editing entries? – Derek Hogue Jan 3 '14 at 20:40
  • Yes two other users. I can't 100% eliminate some sort of user error, but they are knowledgable with EE and we've never had this problem before. I'm looking into trying to add some developer logging in the relationship code in EE now. – 2bsharpdev Jan 8 '14 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.