0

I know this issue has been mentioned before, but I can't find a solution to the problem anywhere.

I don't understand why when you edit a form submission, the fields don't appear in the same order as the form. I know you can edit how they appear in the main entries listings, but this doesn't carry over to the edit page for each individual entry.

I've tried to edit the plugin to do this, but am getting no where as my knowledge of object oriented PHP isn't great enough.

Is there something simple that I'm missing?

I've also tried deleting all forms and creating all the fields in the correct order. But even then, when you add an entry and try and edit it, the submission still appears alphabetically.

Can someone please shed some light on this issue?

Thanks.

Andrew

0

The fields are displayed in the order specified in each form's configuration screen (at the bottom, where you drag and drop fields for the form).

Freeform form configuration screen

Note where it says:

The fields in the right column will be available in this form on output and they will display in this order when using the {freeform:all_form_fields} tag pair.

(It really should include "and when editing form entries in the control panel".)

3
  • Hi Derek, Thanks for your reply. I cannot seem to find this page at all. Could you please send me an example path of how you get to this page?
    – user2497
    Jan 8 '14 at 12:00
  • In your list of forms, click the "gear" icon for each form, then scroll to the bottom of that page. (I assume you're using Freeform 4.x.) Jan 8 '14 at 14:12
  • Hi Derek, This method has provided me with a possible solution. It appears that this option is only available when the form type is set to template. But it doesn't appear if it's composer. So what I'm having to do is create all fields, set the form type as template, add the fields and reorder them and then change the form type to composer and create the form. This means that the fields appear in the chosen order when editing a n entry. However if we ever want to add additional fields this will mean they won't appear in the correct order.
    – user2497
    Jan 9 '14 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.