1

i've an eccommerce with store on OVH's shared hosting and I often receive this error message when i browse the site:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, postmaster@www.griffando.it and inform them of > the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

  • PHP Version: 5.3
  • EE version: 2.5.3
  • Store version: 1.6.0

Have anyone else encounter in the same issue? Thanks

edit: Here there's the error log: https://gist.github.com/9d2f2a1f85374c415042

edit2: thank you all guys, now (i don't know why) the error disappear. I didn't change anything

  • 1
    Without further details nobody will be able to shed any further light on this. Your best bet would be to talk to your host, as there's a fair chance that this is a server configuration issue. Even if it isn't they should be able to provide you with some error logs to aid with debugging. – Dom Stubbs Nov 21 '12 at 18:28
  • @DomStubbs: I already talked with my hosting but they didn't help me so much. Here there's the error log of today but i don't understand much more with that: gist.github.com/9d2f2a1f85374c415042 – migliorosso Nov 21 '12 at 18:49
  • 1
    'Premature end of script headers' could be any number of things, but you could try a) disabling any .htaccess files you may have and b) reuploading any files you've modified recently in case they're corrupt. In all honesty it sounds like you need a better host. – Dom Stubbs Nov 21 '12 at 19:02
6

The most common cause of this error is an issue with your .htaccess file. In particular I have run into frequent problems with:

  • DefaultCharset directives
  • RedirectMatch directives
  • Trying to use Rewrite directives on a server that does not have mod_rewrite enabled
  • Trying to use Apache 1 compression on Apache 2 servers (mod_gzip instead of mod_deflate)

If you've got any of that in your .htaccess, remove those directives and try again. If not, try removing EVERYTHING from your .htaccess, and add it back in one block of directives at a time until you get the 500 error again.

| improve this answer | |
4

As a first step, look at your server error logs. Details about what is causing the error will most likely be there.

If this is happening sporadically, I would guess that it has noting to do with EE or Store and everything to do with your hosting environment.

If you don't find the answer in your error logs, your only option is to contact the web host for further assistance.

| improve this answer | |
4

I did some quick googling on that error, and another possibility is that it's caused by suEXEC. So if suEXEC is installed (e.g. some cPanel servers):

  • Check the suEXEC logs on your server (if you have access to them, probably not though if you're using shared hosting).
  • Make sure your file and folder permissions are correct. For example on my cPanel server I know the public_html folder needs to be owned by myuser:nobody and permissions 750. Everything inside it can be owned by my user and permissions 755, but I know in the past if I took away the group nobody for the public_html folder the whole site came crashing down.

If all else fails, try deleting/renaming EE and just try to get a simple index.php file outputting something, then work your way up from there until you figure out what is causing the issue.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.