0

In a Catch-22 situation where SagePay won't approve a merchant account for client unless we have a working dev site for them to test a transaction on which is set up to integrate with … SagePay.

Anyway, have set up a CartThrob install using Twitter bootstrap to keep things simple with the gateway at checkout set to 'SagePay Europe Offsite (Server)'. However, on checkout I get the following error message:

Error
<url> malformed (3)

Not sure how to troubleshoot or debug. My immediate guess is that the vendor name (which I don't yet have as the merchant account is pending approval) is required for sending a user to SagePay during checkout. Is that correct?

Cole

  • To add - having switched gateway to Offline payments am still getting this error message – Cole Henley Jan 6 '14 at 14:29
1

For the Merchant Service application - a working Test or Live wesbite is required so that the merchant bank, Elavon, can simulate the check out process up to the payment page. This does not need to be integrated with Sage Pay at this point.

| improve this answer | |
0

have you configured your extload.php file to show where your system folder is / is called? That is the file used for the callback url.

| improve this answer | |
  • this is defaulting to 'system' which is the path in use – Cole Henley Jan 6 '14 at 16:44
  • And is system above or below the webroot? Also, how are you defining your gateway choice? In the checkout tag or in the Cartthrob settings? You may have changed it in one place and it's getting overridden elsewhere. – JohnWBaxter Jan 6 '14 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.