2

I have an Assets field on my site. When I click to upload files, the assets box opens as it should, but displays my homepage. Any ideas?

1

Update: based on your comment that you've got a multiple sites installed on the same server:

Make sure the correct system dir is being specified in your index.php and admin.php files, and that you've got valid values for $config['base_url'], $config['site_url'], and $config['cp_url'].

====

An over-ambitious .htaccess re-write rule is commandeering the ?ACT= request, and redirecting the URL to the homepage, perhaps?

Should be easy to test; comment out and/or remove the .htaccess rules, if possible, and see what happens.

5
  • I thought of that and started deactivating .htaccess rules, but to no avail. If it helps, this site is in a subdirectory of another site. The main site has Assets used in the same way and it works fine. The subdirectory site is the one with problems. I tried deactivating both .htaccess files.
    – MDLG
    Jan 6 '14 at 17:45
  • I don't know if this will help, but the site in the subdirectory was not installed from scratch, but is a copy of the main site which I copied to the subdirectory, so there may be a setting that has not been updated?
    – MDLG
    Jan 6 '14 at 17:49
  • Updated my answer to check some paths/config values. Jan 6 '14 at 18:13
  • system dir is correct in index.php and admin.php. In the config.php file, $config['cp_url'] is correct, $config['base_url'] is set to blank ("") and $config['site_url'] is nowhere to be found...
    – MDLG
    Jan 6 '14 at 18:22
  • This definitely is a case of an Assets AJAX request being redirected somewhere. Are you using 301 redirects in .htaccess? Those will drop all POST data and Assets uses POST exclusively in AJAX requests. Have you tried the assets_site_url setting?(docs.pixelandtonic.com/assets/using/config.htm) Jan 7 '14 at 7:41
1

Do you have an index.htm page in your site root? That can cause a similar issue for Assets.

Try adding this config line to your config.php to tell Assets the path to your site index:

$config['assets_site_url'] = "/index.php";

0

Issue solved. The path in "URL of Upload Directory" under File Upload Preference was set as an absolute path for some reason. I changed it to an relative path and it now works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.