0

This is on EE 2.7.2. I have just moved a site to a new server. The site was working perfectly before hand, but now that it was migrated all the backend form submissions only return JSON. Some examples:

  • Save an entry, I get a page with just: {"message_success":"Entry Has Been Updated"}
  • Clear the cache: {"message_success":"Cache files have been deleted"}
  • Loading entries page: big list of JSON entries
  • Saving an entry: {"message_success":"Entry Has Been Updated"}
  • Sometimes while reloading one of these JSON pages, it just logs the user out and shows a page with "Logged Out" and I have to wait a few minutes before I can load the backend login form.

Some submissions seem to work: Saving Template General Configuration: works as expected

I was wondering what could cause this. I am assuming it is a path setting, but wasn't sure what would only output JSON instead of loading a page. I also noted that there are no JS errors, but the developer log is full of this message:

Deprecated function generate_json() called in system/expressionengine/third_party/structure/mcp.structure.php on line 220. Deprecated since 2.6. Use the native JSON extension (json_encode()) instead.

Is anyone familiar with this issue and what may be causing it? Thanks!

0
3

The issue was related to PHP. This was a mediatemple GS server and it had the PHP set to 5.3.27 FastCGI. I had to change this to 5.3.27 CGI (stable) and this seemed to clear up all the issues. Hopefully this may help someone in the future as the issue was unexpected and not clear what the issue was.

Not the answer you're looking for? Browse other questions tagged or ask your own question.