0

So I've looked at this post:

When trying to update indexes a get a JS error and it never finished

I added $config['assets_site_url'] = '/index.php'; to my config file but I'm still getting this error Uncaught SyntaxError: Unexpected token < matrix_multi_upload.js:166:

enter image description here

Does anyone have any other ideas on what could be causing this issue?

Matrix allows me to upload photos, but I REALLY like MMU!

Thanks for the help!

4
  • I am having the same error - Was this ever resolved????
    – Corey
    Feb 24, 2014 at 17:53
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. Feb 25, 2014 at 0:58
  • Thanks Jeremy, I asked the question a week ago and received no responses... desperation has set in.
    – Corey
    Feb 25, 2014 at 15:27
  • I understand. Using the comments on the question is the best place to ask questions about a question, rather than posting as an answer. There is now an answer below. Feb 25, 2014 at 19:08

2 Answers 2

1

That setting is "mmu_site_url" instead of "assets_site_url", for Matrix Multi Upload accessory :)

Source

4
  • I'm still getting the same error. What gives? :) Setting $config['mmu_site_url'] = '/index.php'; doesn't do anything for me in my config.php file :/// It looks like it's referencing this Uncaught SyntaxError: Unexpected token < matrix_multi_upload.js:166 I even updated that file from MMU's GitHub page to no avail. Jan 9, 2014 at 16:30
  • I have confirmed that the photos are uploading, but the rows are not being created in the matrix field. Jan 9, 2014 at 16:34
  • Shoot over CP access to [email protected] - have to take a closer look :) Jan 9, 2014 at 20:43
  • Hi Andris, email has been sent! Jan 10, 2014 at 21:45
0

The console log message SyntaxError: Unexpected token "<" may be caused by a missing javascript file, intercepted by some 404 or HTACCESS rule. So, ...

  • Is the themes folder for Matrix MultiUpload there, in /themes/third_party/matrix_multi_upload?
  • Is it accessible over HTTP?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.