1

I have a Grid field with four columns

  1. Relationship
  2. Select Dropdown, Output Formatting = None
  3. Select Dropdown, Output Formatting = None
  4. Text Input, Output Formatting = None

The problem I am having is that when I output the value of column #3, it is always get wrapped in a <p> tag.

I have checked my templates to see if there is any post processing being done(there wasn't)

{foo orderby="some|columns|here" sort="asc"}
    ...
    {foo:bar}
    ...
{/foo}

This is very, very odd to me since if there is a problem with output formatting, it should be reflected in column #2 since they are setup the same.

Any idea why this is the case?

NOTES:

  • I am on EE 2.7.2
  • I read this forum thread and double checked if my output formatting option is set right
  • I read this and tried to apply the solution but it did not work. To be fair, the poster was talking about a native select dropdown, not a grid column select dropdown
2
  • got exactly the same issue, but whatever i do, nothing seems to fix it. – Jelle Dijkstra Mar 10 '14 at 13:36
  • I'm also having this problem. Renaming the fields is NOT working. Neither is clearing the cache – SteveO Apr 22 '14 at 23:53
3

After a new channel and new field group and channel fields, I suddenly had the same problem for an existing channel(+fieldgroup)'s entries. It certainly wasn't a template issue.

I'm pretty sure I fixed it now: try renaming the grid field's Field Name (and Publish Label to match) to something else. It should work then (though mind that the template tags would need to be updated to reflect this change), and you can rename it back again to what you have it named now.

Maybe clearing the cache (Tools > Data > Clear Cached Data) would have done the trick, you might try that first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.