0

In the process of updating a site from from EE v2.6.1 to EE 2.7.3, the update stops partway through with this error:

Webmaster name or email missing from Email Configuration settings.

Has anyone else encountered this error? Does anyone have any advice on how to work around it?

8
  • Does your installation have those fields configured ? Jan 13, 2014 at 3:26
  • Yes, they are present in the EE 2.6.1 installation. Jan 13, 2014 at 3:35
  • Have you run the install wizard ? Jan 13, 2014 at 5:40
  • Yes, the install wizard makes it through the 2.7.2 update, but then chokes at the very end and produces the error message above. Jan 13, 2014 at 6:25
  • I just tried again, restarting from the beginning, but ran into the same problem. Jan 13, 2014 at 6:26

1 Answer 1

0

EllisLab Support helped me figure this one out, but just in case anyone else ever runs into this problem, here was the solution:

It was presumably a third-party add-on that was responsible for the error, and the add-on update process is the next-to-last step the update wizard runs before updating the EE version number in the config.php file.

I just needed to check that the EE 2.7.3 changes were reflected in the database, which meant checking that the following database fields were updated to a length of 75 characters.

  • exp_members.email field
  • exp_email_cache.from_email
  • exp_email_console_cache.recipient

These had, in fact, been updated correctly, so all I needed to do was update the version in the config file to "273," remove the "installer" directory from the server, and log into the control panel to update the add-ons.

Now everything works just fine. Many thanks to Robin Sowell at EllisLab Support for helping me sort this out!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.