0

My template's <head> tag is defined as a snippet combined with preload replace variables, as per Low's idea (http://gotolow.com/blog/snippets-and-preload-replace-variables). On one or two templates, however, this technique won't cut it and I need to use a full embed. That's a shame, but there you go.

Thing is, I'm finding that if I am logged into the CP as an Admin (a member group I created for the client to use for basic site editing, with much less control than a superadmin), the embed doesn't embed. So the page has no <head> tag at all, with all of the rather unfortunate consequences that that implies.

I'm racking my brains to think what setting in the member groups settings might be causing this; if I'm logged in as a super admin (or not logged in at all) then the embed is processed normally.

Any ideas?

1

And as I submitted the question (probably because of the process of typing it out logically) it dawned on me. The issue wasn't in the member group settings, it was in the access permissions under template management. Admins were not permitted to view that embed template for some reason. Corrected and now all is working.

| improve this answer | |
  • Glad you found a solution! – Nick Benson Jan 14 '14 at 15:52
  • Mark your answer as right. – Robson Sobral Jan 14 '14 at 17:39
  • Robson, it won't let me do that for two more days, for some reason. I'll try and remember to come back and do it, but apologies in advance if it slips my mind 2 days from now. – RickL Jan 14 '14 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.