1

I am trying to add a field that allows users to embed a youtube or third party video code. I have the field configured to be a textarea with no formatting. When I try to add the embed code in an entry form EE turns the any < into a special characters. This cause the video to not load correctly on the front-end website. I tried changing the field to Rich Textarea or Wygwam but the issue still occurs. You can see the error on this page (http://mtcorps.org/blog/view/secretary-jewell-announces-1-million-private-funding-commitment).

I am running EEv2.7.2. Any help is appreciated.

1

You'll notice it's also adding paragraph tags around the content of your text area - double check to ensure that when you have it set as a textarea fieldtype you also have formatting set to "none". It seems you have have XHTML formatting on the field currently.

One thing you might consider, if you won't want to have users inserting embed code (at least for youtube or vimeo) is DevDemon's awesome and free fieldtype called Channel Videos. As a fieldtype, it allows you to search youtube and vimeo from the control panel and allows you to set up all the custom parameters you want within the add-on, removing those aspects of the setup from the user-admin side. And at the template level, it does all the code insertion for you and applies the parameters you have set in your add-on's preferences. It doesn't help you with third party embeds - for that you'd still need a field like you're trying now - but for youtube and vimeo, it's excellent.

3
  • I doubled checked, the formatting for the textarea fieldtype is set to "none". I can't use DevDemon's plug-in in this instance, but it is usually a great thing to use. Any other ideas why it is formatting just the < instead of other special characters like >?
    – Mike Zens
    Jan 17 '14 at 18:30
  • Is it doing it with even a completely new posting? I'm wondering if perhaps the field was once set to xhtml encoding and was changed to none, but anything submitted to the channel prior to that was not changes (wight he checkbox that appears to allow you to change all existing entries when a formatting change is made). It's not just changing certain characters, it appears to be adding <p> tags as well, which would be an indication. You could try changing it to xhtml, submitting, and then changing it make to none and selecting the checkbox indicating you would like existing entries updated Jan 19 '14 at 21:25
  • The error is occurring on new postings and while editing postings. I also triple checked, the field formatting is set to none.
    – Mike Zens
    Jan 20 '14 at 16:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.