1

I have created a Channel Form that is intended for guest users (not logged in) to submit information including up to two image files. The form uses a Matrix or Grid field (I've tried both) for the image files. The form works great except that the image files are not uploaded. If I login as a Super Admin and submit the form, the files ARE uploaded, which leads me to believe it is some sort of permissions issue on the upload directory.

I set /images/uploads and /images/uploads/habitats to 777 to try that, and it is still not working.

FORM CODE:

{exp:channel:form channel="Habitats" return="/habitats/thank-you" 
logged_out_member_id="6" 
rules:habitat_story="max_length[500]" 
rules:habitat_comments="max_length[500]" 
rules:habitat_management_practices="max_length[500]" 
rules:habitat_category_other="max_length[50]" 
rules:habitat_program_other="max_length[128]"
}

...

<fieldset>
    <label for="habitat_photos">{label:habitat_photos}</label>
    {instructions:habitat_photos}
    {field:habitat_photos}
</fieldset>

...

{/exp:channel:form}

Can anyone offer a solution or advice to fix my problem? Thanks!

3

By default, the members of the guests group cannot upload to EE; this is a permissions issue, but, it's permissions within EE, not with the filesystem, which is why CHMOD'ing to 777 didn't help.

Here's a link to a previous post with this problem, and a solution.

1
  • 1
    Thanks, Nick. This may or may not be a great solution. However, I realized I forgot to give upload permission to my new member group (for the anonymous submitters) in the File Upload destination preferences. Now it's working!!!
    – Amy Witty
    Jan 15 '14 at 21:20
0

I realized I forgot to give upload permission to my new member group (the one I created for the anonymous submitter) in the File Upload destination preferences. I went in and did that, and now the form is working correctly. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.