0

I've setup Solspace Facebook Connect to do passive registration. However, when I test this by logging in with my facebook account the email used for the EE member registration is the facebook email like c414b91c90b55584f779f052531f225b@facebook.com instead of the user "real" email account, even though I'm including "email" in the permissions parameter on {exp:fbc:login}

Is there something else I have to do to get the real email address to be used for EE member passive registration?

2
  • What version of FBC are you using? What version of EE are you using? Are you logged in when you use {exp:fbc:login}? Can you show your {exp:fbc:login} code? Also, is your Facebook email address the same as a pre-existing email address in your EE database? – Solspace Jan 18 '14 at 21:16
  • I'm using FBC 2.1.3, EE 2.7.2. In this case, no I'm not logged into EE when using {exp:fbc:login}. The scenario is that this is a user without an EE member account. They login using FBC and it passively creates an EE member account for them. This is being done sucessfully it's just the email address I'm having trouble with. Your comment about the it using the same email address as an existing member was the key. It was the same email address. I've deleted the existing member and re-tried with that same facebook account and it works. – Benek Lisefski Jan 19 '14 at 1:26
0

The answer was supplied in comments from Solspace. The "real" email address was not being used for passive registration because the email address was already in use for another EE member account. If the email address is unique it works fine.

0

I was getting the same issue and was able to resolve it by using an FB app created several months earlier (just for testing purposes) that used the corresponding 2.2 Facebook API.

2
  • Can you please expand on your answer to better help others? How did you implement a new FB api? Custom module or plugin? – jrothafer Sep 15 '15 at 0:38
  • I simply added a Facebook App ID and Facebook App Secret code of a previously created 2.2 FB app that I created on facebook several months ago. So I filled the input fields on Solspace FBC module preferences page with the new data and the issue was solved. – Tamas Sep 16 '15 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.