2

I'm in the middle of a very very complex EE1-EE2 upgrade and found that I made a mistake and did not uninstall LG Polls before doing the upgrade and am now getting the following error on front end pages

enter image description here

I've commented out template code that references lg polls and also changed the lg polls fieldtype to a text input but the error persists. I'd really rather not have to rollback and do the upgrade again.

Is it possible to uninstall the module using something like Navicat and have these errors disappear?

4

Funnily enough I'm going through exactly the same process at the moment.

I'm undertaking a conversion from LG Poll to VWM Polls.

If you don't care about these errors, you can just set the field's type to 'text' in the exp_channel_fields table, which will at least get your site working again. Then if you don't want to upgrade or migrate LG Polls you can delete the tables, though no need really.

2
  • That's perfect 'cause migrating poll data is not necessary.
    – CreateSean
    Jan 16 '14 at 16:08
  • 2
    ah, you're lucky... migrating the poll data is not straight-forward! Just to clarify too, changing the poll field to a text input via the CP will only do one of the LG fields (lg_poll_d), but lg_poll_q you'll need to do in the DB. Jan 16 '14 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.