4

I am using FL master config and works a treat (brilliant) on local (MAMP) but when uploading/accessing the dev server just a blank screen appears and also the same for the system login (so can't turn on debug), I know EE works okay on this host (and the db is okay – EE runs fine using a default fresh install). I tried another host and the master config approach works fine! so can only think that the dev host has a prob with the master config approach, checked and dbl checked settings so can't be that, looking into using reelocate but spoilt by the ease of FL's master config approach (so easy!), so wondered if anyone had come across this before and found some possible solutions?

Thanks.

  • If you just add exit('here'); to your env config, does that show when loading the index on the troublesome host? That should confirm at least that the right env config is being loaded. – Iain Urquhart Jan 20 '14 at 5:02
  • Thanks Iain, would that be added to the end of the 'env config'? Sorry not sure at which point that would be need to be added – sounds great though, as hopefully can reduce the problem area… – user2632 Jan 20 '14 at 7:31
  • Triple check your config.env.php file to make sure your domain is typed out correctly. My guess is that you're getting the white screen because the Master Config doesn't recognize the domain and is thus trying to connect with your local credentials. – Erik Reagan Jan 20 '14 at 13:31
  • Thanks guys, unfortunately on adding exit('here'); to the 'env config' didn't make any difference, still not display anything (blank screen for both index and login), I've checked settings again on the config.env.php and the staging subdomain is correct in that if I navigate to a static HTML file eg: staging.mydomain.net/test.html I can see that file (and DN um / pw and server correct), I'm just wondering if there is an exception on some hosts as to the actual url: staging.mydomain.net might this be something else… ????staging.mydomain.net, (also using FTP not tower/beanstk incase a poss prob) – user2632 Jan 20 '14 at 23:45
  • Tried disabling extensions on the config (via ftp) just can't get rid of the w s o d, thinking about looking into another host though would like to find a reason first so I can avoid this next time on some shared hosting – user2632 Jan 21 '14 at 20:17
1

A WSOD after installing a Master Config probably means that the new config isn't being loaded correctly. This could be because the include path in EE's config.php doesn't correctly refer to the Master Config file, or because the environment-based path generated by the master config doesn't correctly refer to an environment config file. It could also be a syntax error somewhere in any of the config files.

Some troubleshooting steps:

  1. In your EE config.php, before you include the master config file, echo() the path in your include statement. If you see the path displayed when you reload the page, it means EE's config.php is being loaded properly, but your Master Config file (config.master.php) file isn't. There's probably a typo in the path, such as an extra/missing slash, an extra/missing ..., etc.
  2. In your Master Config file, insert an exit("test") at the very beginning. If when you reload the page you see this message (probably twice), it means your Master Config file is being loaded properly, but some setting is causing an error.
  3. Try block-commenting out config settings until it works. If you comment out all your config items and still have a WSOD, probably there's an error loading your environment config file, so the troubleshooting process repeats, one layer recursed...
  4. First, check to make sure the domain name you're accessing matches the hostname of an environment you have specified, and that the environment has its env variable/constant defined. If it does, check to make sure your config.[env].php file actually exists.
  5. In the Master Config file, just before the include statement that includes the environment config file, echo() that path, and check as before to make sure it doesn't have typos.
  6. Try adding a exit("test"); at the top of your environment config file. If you see that message when you reload the page, it means the config file is being loaded properly, but some setting is causing issues. Start block-commenting out config directives until it works.

(Since you mention that this Master Config works on your local machine, but not on the server, it's probably an issue with the hostname not matching up with a defined environment/env in the master config. In that case, you could skip to step 4, but I'm including the whole process for the sake of completeness...)

p.s. Also double-check to make sure that files on your server are exactly the same as the files on your local machine... I know that sounds obvious, but I cringe at how many times (before the age of easy Git deployments) I saw a WSOD because I forgot to upload a file...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.