0

The entry I'm having problems has a Matrix field with over 100 rows, on 8 columns of data (7 simple text fields, 1 dropdown with 2 options). When attempting to add just one more row and hitting the submit button, the server seems to be choking and coming up with a the default 404 page set for the website...no error messages or anything to tell what's actually going on. Checking the PHP error logs also shows nothing up.

I've attempted to up the 'memory_limit' to 2048M and the 'max_execution_time' to 300, but neither of these makes any difference.

Running EE v2.5.5 and Matrix v2.5.10, there's are also another Matrix field, and Assets field and a WYGWAM field on this entry.

A strange thing is that I can update this entry on my local MAMP setup, but not the Production server.

  • Is the session_save_path correct / working? I've had this exact same problem a couple of times with far less rows but setting max_execution_time as you have solved it. – Damien Buckley Jan 27 '14 at 2:46
1

As you suspected, you're bumping into some resource or config setting limit, you just have to figure out which one. A common culprit (other than memory_limit), is max_input_vars.

| improve this answer | |
  • This particular server is running as a VPS using cPanel's WHM. Looking at it's PHP config editor, looks like I'm not able to edit that value specifically. If adding a php.ini file to the server directly for this domain, at what level to I put it, the /public_html/.. directory? – Brendan Underwood Jan 27 '14 at 2:29
  • I believe if you put it there, it would apply to all (any) domains you have under there. – Brad Bell Jan 27 '14 at 2:32
  • Weird thing is that it works locally, and the max_input_vars show the same value in PHP info for both local and production. – Brendan Underwood Jan 27 '14 at 2:37
  • Try doing a phpinfo() on both and use a diff tool to see what the differences are. – Brad Bell Jan 27 '14 at 2:38
  • Not sure my skills know what you're talking about at this level. – Brendan Underwood Jan 27 '14 at 2:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.