1

I'm updating a wine store site I've built for a client (http://shoptipsy.com) to add the Fedex Shipping plugin to their current Store-powered shop.

I've got the plugin integrated with production credentials supplied by Fedex. All seems to be working except that the shipping charges that the plugin returns are the same no matter how many items I have in my shopping cart.

So if I add one bottle of wine to the cart, the shipping charges for the various FedEx options are the same as when I add 100 bottles to the cart. I see the same behavior whether I'm testing on my local dev setup or on my staging server. Also, I've tried to check the charges the plugin is returning against estimates that FedEx supplies with its website calculators, and they don't match.

This obviously won't work. I can't enable the plugin on my client's site if the shipping charges are not being calculated correctly.

Anyone else run into this issue? Is there a way for me to check what info is being supplied to the FedEx API by the plugin to see if the order_weight is being taken into account?

Thanks for any info anyone has, Adam

0

This sounds like an issue I came upon where Store's real-time shipping rate caching was not clearing when products changed in the cart or the shipping address changed. So if during testing you loading the shipping rate page, that rate would be cached regardless of new/deleted products or zipcode change.

Upgrading to Store v2.2.0 fixed this issue for me.

FROM 2.2.0 RELEASE NOTES: "Fixed overzealous caching of certain shipping extension HTTP requests causing shipping prices to not update"

https://exp-resso.com/docs/release_notes.html

| improve this answer | |
  • 1
    Yes, updating to Store v2.2.0 fixed my issue. – Adam Snetman Feb 8 '14 at 14:27
0

Does Expresso Fedex Shipping plugin take product weight into account?

Yes. Unless you have enabled "free shipping" for any items on the publish page.

If that's not the problem, then it's probably best that you email support@exp-resso.com about this one, so that we can take a deeper look into your specific site.

| improve this answer | |
  • Thanks for the response Adrian. I have not enabled "free shipping" for any of the items. I have an email in to the support address associated with Case #1303, but I haven't received a response since I sent it on 1/16. What do you suggest I do? – Adam Snetman Jan 24 '14 at 0:20
  • Adam - I see your ticket, I'll follow this up with you there. – Adrian Macneil Jan 28 '14 at 20:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.