0

I'm using EE 2.6.0, has anyone run into an issue where they get the following error when trying to upload a image: Thumbnail could not be created for the image. Please make sure the thumbnail directory is writable.

I've checked the usual suspects, the path is correct, permissions on the folders are ok. I've tried changing the image library from GD2 to imagemagik. I can upload other file types to the folder (pdfs etc..) just not images.

Strange thing is, it was working ok, the client left the site for a few months, I've just returned to it to finish it off. I was able to upload ok 6 months ok, nothing's changed in the meantime.

Thanks,

1

Checked the permissions of the upload destination folder, make sure that PHP has permission to create files and folders. If the 'thumbs' folder exists in this destination make sure nothing odd has happen to that, and it's permissions are set correctly. EE should have created it but in the past I've deleted whole directories and uploaded local folders with a thumbs folder inside. This can sometimes result in the FTP user (you) as the owner and PHP can't alter it.

Another place to look is the tmp folder for the server. I've had this issues as well. The PHP img library (GD2/imagemagik) needs a temp folder to save the image while manipulating it. Make sure your Apache vhosts conf file allows the site to access the system tmp folder and it's permissions are correct.

You, too, should make sure the path to ImageMagick is right, in case you're using it.

I'm assuming it's an Apache server. Also depends on how you're administering it. I've had Plesk completely screw up a vhost file in this way before.

1
  • Hi Guys, thanks for your help. I've checked everything you mentioned and it all looks ok. I've got it sorted out now, I just changed the name of the existing _thumbs folder, tried to upload a new image, EE created a new _thumbs and uploaded the file correctly. Very strange as the new _thumbs folder has the same permissions and ownership as the old one. but it's working so I'm not going to question it.
    – Mark
    Jan 23 '14 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.