2

I have a multi-page freeform pro form which breaks every time the user uses the back button to go back to a previous part (the dreaded "action is invalid error").

I can only get it to work properly by disabling secure forms globally in the control panel - is there no way to disable it just for this one form through a parameter? Using FFP v 4.1.3 on EE 2.7.3

5

Unfortunately there is not - when Secure Forms is enabled, EE requires every POST to contain a valid XID. More and more I'm just disabling Secure Forms on any site which takes user submissions because it brings so many headaches.

5
  • Thanks Derek, thought as much - though I could swear freefrom had a secure="no" parameter :) Maybe I'm confusing this with another add-on. Jan 29 '14 at 13:11
  • Low Search used to have a secure parameter, but he removed it (I think because EE 2.7 disabled its ability to work). Jan 29 '14 at 13:18
  • That's the one I may have been thinking about, OK. Jan 29 '14 at 14:49
  • 2
    Derek is right about the secure="no" param. However, you could (manually) set the csrf_exempt column to 1 in the exp_actions table for the action in question, which should solve it, too.
    – Low
    Jan 29 '14 at 15:21
  • Can confirm this little workaround works fine - thanks Low! Jan 29 '14 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.