0

I recently updated to EE 2.7.3 and noticed that I am getting the following error at the top of all my pages:

Parse error: syntax error, unexpected 'II' (T_STRING) in /var/www/vhosts/mysite.com/eesystem/expressionengine/libraries/Template.php(3276) : eval()'d code on line 1

Line of said template reads:

<?php  if ( ! defined('BASEPATH')) exit('No direct script access allowed');

Any clues what is causing this and how to resolve it?

Thanks.

2

Actually, that error message points to line 1 of eval()'d code, which is executed on line #3276 of Template.php:

eval("\$result = (".$cond.");");

This is part of parsing conditionals. So it looks like there's a problem with one of your conditionals. And since you say the error occurs on each page, the conditional most likely is present in a header/footer snippet/embed in your templates.

Check your templates and snippets for a conditional that uses || and verify its validity.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.