2

I'm on Assets 2.2.2. Today it told me to update so I clicked the update button. This happened:

A Database Error Occurred
Error Number: 1146
Table 'db509793644.exp_assets' doesn't exist
UPDATE exp_assets SET file_path = REPLACE(file_path, "}/", "}")
Filename: third_party/assets/upd.assets.php
Line Number: 298

Now in Add-ons -> Modules I get @@@VERSION@@ as the version. No clue on this one...

2 Answers 2

1

Assets doesn't have any sort of self-updating capability. Moreover, “@@@VERSION@@@” is a flag Assets only uses in its source code. It gets replaced with the actual version number through our build script, before it ever becomes a downloadable .zip on Devot:ee.

I have no idea what's going on here, but it smells fishy. You should really take some time to investigate where your Assets files came from, and how they “randomly” made it to your server.

0

This errors is pretty specific. It says your 'db509793644.exp_assets' table doesn't exist.

Get into phpmyadmin or whatever tool you use for navigating your database and look for "db509793644.exp_assets". Is that the correct name of your table? Specifically, the "db509793644" part?

If that is the correct table name and the table is not there, you'll need to restore from backup. If you don't have one, check with your host. They will most likely be able to pull from their backup. You might want to have them restore the whole site to the state it was at before the update...

1
  • I had the same error on locally as well as on the dev site. I ended up having to completely uninstall Assets, reinstalled it and it worked again. Still scratching my head on how it happened.
    – brunam
    Feb 7, 2014 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.