3

I'm just wondering if there are certain guidelines to bear in mind if you want to ensure an EE site stays fast. What typically are the things that slow down an ExpressionEngine installation?

  • Does the number of entries in the system have a large impact?
  • How about the number of global variables you've set (especially when using Low Variables excessively)?
  • Does the number of addons in the third party directory play a role?
  • What about a site that was upgraded from EE 1.xx?

I realise this is a lot of questions. I'm just trying to work out why one of my sites is way slower than the others (same hosting).

Cheers

Jim

3
  • Jim, are you using Template Debugging? Can you see there what's taking a seeming excessive amount of time? I think regarding the questions you have, the answer without more specifics can be probably no better than "it depends". If there's no particular process that seems to be taking a lot of time, but instead similar processes to what's over on the other site seem to take longer, then these more general things you're mentioning could be the culprits. I would guess that the most potentially hazardous one is entries (and total number of fields). If you try a template without recourse to entries – Adam Khan Feb 7 '14 at 10:43
  • This question seems impossible to answer definitively because it's so broad I'm putting it on hold. Please feel free to edit to get more specific. – Anna_MediaGirl Feb 7 '14 at 19:04
  • You're right Anna - it's more of a general/best practise question rather than anything absolutely specific. – Jim Pannell Feb 14 '14 at 9:14
4

There's a boatload of great resources on this topic. Here are a few recommendations to get you started:

Install the EE Debug Toolbar
http://devot-ee.com/add-ons/ee-debug-toolbar
Adam's suggestion of enabling template debugging is a good one. This add-on is a great way to uncover potential issues. Be on the lookout for high query counts and process bottlenecks. There isn't a hard and fast rule for what's excessive, as it depends largely on the functionality and content structure of your particular site / page.

Make Sure You're Using Appropriate Caching Where Possible
http://ellislab.com/expressionengine/user-guide/optimization/caching.html
If you're relatively new to EE, this one is huge.

Review the Answers for Related EE StackExchange Questions
https://stackoverflow.com/questions/13041463/whats-the-optimal-amount-of-queries-an-expressionengine-page-should-load
Add-ons and front-end performance
What are the recommended ways to get to the bottom of slow load times in EE?

Do a Google Search for EE Performance
https://www.google.com/search?q=expressionengine.com+performance&oq=expressionengine.com+performance&aqs=chrome..69i57.4743j0j4&sourceid=chrome&espv=210&es_sm=119&ie=UTF-8

Check Out Stash
http://devot-ee.com/add-ons/stash
There are a 101 uses for Stash, most of which will help keep your template code more dry and efficient. For starters, I'd recommend checking out Stash Variables, which are fairly simple to wrap your head around (some of the Stash concepts can get complex quickly) and can be super useful in a variety of situations.

Give this Podcast on EE Performance a Listen
http://ctrlclickcast.com/episodes/ee-speed-optimization
There are some great tips in here.

Make Sure the Non-EE Parts of Your Site are Optimized
http://developers.google.com/speed/pagespeed/insights/
If you haven't done so already, it might be worth running your site through Google's PageSpeed tool. Generally speaking, it's a good idea to make sure you're combining and minifying your JS and CSS assets, optimizing your images, and reducing the number of http requests wherever possible.

1

I noticed myself that if else statements don't work like you think they do! Even if your if statement matches, also the code in the else part is executed. However you won't see the output.

I ran into this problem and my site load time was about 3 seconds. I used the add on switchee ( http://devot-ee.com/add-ons/switchee ) which makes real if else statements. This sped up my site with almost 2.5 seconds, so now loading within 0.5-1 second!

1
  • Switchee and if:else are part of my default installation, so that isn't the issue for me. Thanks though. – Jim Pannell Feb 6 '14 at 23:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.