1

For CartThrob and Expresso Store guys, just had this email from PayPal this morning:


In an upcoming system upgrade, the following API endpoints will be updated:

  • api.paypal.com
  • api-3t.paypal.com
  • svcs.paypal.com

Please make sure you are ready for this event by consulting with your technology team or individual(s) responsible for your PayPal integration.

When is this happening?

This upgrade will occur on 26 March 2014 at 5:00 p.m Australian Eastern Daylight Time (AEDT).

* If you are integrated with a partner or a cart, please view our FAQs for more information.

What do I need to do?

Your technical team or individual(s) responsible for your PayPal integration will need to examine your current integration and make necessary changes as outlined below.

If your site is:

  • Calling our APIs with a hardcoded PayPal API endpoint IP address, rather than using DNS resolution:

    • Impact of upgrade: API calls will timeout or your will encounter an internal error from your system.

    • You need to: Use DNS resolution to access our API endpoints and/or open your firewall to the new IP addresses which will be communicated later.

  • Using HTTP methods other than GET, POST, DELETE and PUT:

    • Impact of upgrade: API calls will return HTTP/1.0 400 Bad Request or HTTP Error 405 Method not allowed.
    • You need to: Send the API requests using one of the allowed methods. Heartbeat calls using the HEAD method won’t be allowed.
  • Using the HTTP 1.0 protocol:

    • Impact of upgrade: API calls will return HTTP/1.0 400 Bad Request.
    • You need to: Update your code to HTTP 1.1 and include the Host header in the API request.
  • Needing firewall changes to allow new IP addresses:
    • Impact of upgrade: API calls will error out if your system responsible for making API calls to PayPal is behind a firewall that uses Access Control List (ACL) rules and limits outbound traffic to a limited number of IP addresses.
    • You need to: Update your firewall ACL to allow outbound access to a new set of IP addresses we will be publishing. Test your integration on Sandbox (see the IP addresses for Sandbox API endpoints). The list of new IP addresses for our Live API endpoints will be posted here when available in January.

Will this require add-on updates? And if so, will it affect v1 versions of the software too?

1

This won't impact CartThrob… either version 1x or 2x.

| improve this answer | |
2

This should not have any impact on Expresso Store (both versions 1.x and 2.x). We use DNS resolution and standard HTTP verbs, so none of the changes above will affect Store.

(and we use PayPal on our own site, so if anything does happen, we will be the first to know about it!)

| improve this answer | |
  • Cool, good to know. :) – Tyssen Feb 10 '14 at 3:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.