1

has anyone experienced an issue with channel entries not saving due to certain words? I'm updating a site with new content from the client, however when I put the new text in and save, the page just returns me to the front end of the site, without saving the entry. Through trial and error, it will save if I remove one or two words from the text. When I put those words back in, the problem returns.

There doesn't seem to be anything unusual about the words, they just seem to random words Expression Engine doesn't like.

I'm using EE 2.6.0.

Thanks,

  • When you say, "returns you to the front end of the site," what URL are you seeing? Does it start with admin.php or /system/? – Alex Roper Feb 11 '14 at 11:03
  • Hi Alex, thanks for your help. It returns me to the home page of the site, so the EE backend is gone. The URL it returns is: mysite.com/ie/system/…. It's a pharmaceutical site, the words it won't accept are: omeprazole and ciclosporin. If I remove those words, the entry updates and saves correctly. – Mark Feb 11 '14 at 12:40
  • In what field are those words being added? The title or url title, or another field? And if another custom field, what fieldtype is it? – Jean St-Amand Feb 11 '14 at 14:18
  • Are you using Zoo Flexible Admin or Structure add-ons on your site? – Alex Roper Feb 11 '14 at 19:27
  • Hi guys, sorry it took so long to get back to you. They're being added to a Matrix field with Wygwam. I'm not using Zoo Flexible Admin or Structure. I've switched off mod_security as recommend be Jeremy below, but the issue remains. Any help much appreciated. – Mark Feb 19 '14 at 16:19
1

Generally this is a sign that your server has mod_security enabled. You'll want to disable it, or have your host do so, or at least loosen up the settings on it.

Basically, mod_security is seeing words that could be parts of rogue SQL queries coming in via POST, and it blocks them from getting passed to the script as a preventative measure.

  • Hi Jeremy, thanks for your help. Sorry to be reopening an old thread, but I've switched mod_security off on the server and the issue remains. Any ideas? – Mark Feb 19 '14 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.