1

Assets doesn't seem to use the same settings for file uploads as what is set in the default file manager of Expression Engine.

I've made an upload location, only for images not larger than 4M and with a resolution lower than 2600x2600.

Images should only be gif, png and j(e)pg. http://ellislab.com/expressionengine/user-guide/cp/content/files/file_upload_preferences.html#allowed-file-types

But in Assets I am able to upload images with a greater resolution. I am also able to upload tif and bmp files. (But only those.) Only the 4M max upload size setting is working.

Is this normal behavior, and if so, is it possible to change that? Otherwise, what is going wrong?

Thanks in advance.

1
  • 1
    I've found the array where the filetypes are defined. In the current version of Assets (v 2.2.2) it can be found on line 73 of the helper.php file. I've also edited the language file (look for images_only_allowed), to make it more clear what image file types are allowed. So only the image resolution issue remains.
    – Diederik
    Feb 12 '14 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.