1

I keep getting this error message:

The file you are attempting to upload is larger than the permitted size.

I can't find where I can set the limit in Freeform.

My PHP upload_max_filesize is set to 2M and the file I am trying to upload is less than 100K.

1 Answer 1

1

You may want to check a couple more php.ini settings.

post_max_size - the maximum size for a post request including any files and any other text fields

memory_limit - your memory limit also has to be large enough to hold the largest upload you will accept

And lastly, the upload location preferences for the location you've selected to use in Freeform has its own maximum file size setting. This can be found by editing the upload location in File Upload Preferences in the control panel.

1
  • 1
    Thanks. I updated the setting Maximum File Size (in bytes) in Content > File Manager > File Upload Prefernces to 2097152 which = 2MB. This fixed it.
    – KoalaKid
    Commented Feb 14, 2014 at 2:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.