1

I'm using Expresso Store 2 with the latest download of 2.2.0 and using EE version of 2.7.2.

When log into the CP and then try and view the site I get a PHP Error page with the following lines:

A PHP Error was encountered
Severity: Warning
Message: include(/Users/grahamcopekoga/Documents/sites/vintageceramics/fukuoka/expressionengine/modules/member/mod.member_register.php): failed to open stream: No such file or directory
Filename: composer/ClassLoader.php
Line Number: 269

AND THIS:

A PHP Error was encountered
Severity: Warning
Message: include(): Failed opening '/Users/grahamcopekoga/Documents/sites/vintageceramics/fukuoka/expressionengine/modules/member/mod.member_register.php' for inclusion (include_path='.:/Applications/MAMP/bin/php/php5.4.10/lib/php')
Filename: composer/ClassLoader.php
Line Number: 269

AND THIS:

Fatal error: Class 'Member_register' not found in /Users/grahamcopekoga/Documents/sites/vintageceramics/fukuoka/expressionengine/third_party/store/src/Store/Service/MemberService.php on line 23

I'm on a test server running MAMP. When I log out of the CP I can view the site, so its a login in issue with Store.

Does anyone know why?

Many thanks in advance.

6
  • 1
    Hmmm...that's certainly not a common error and the first thing that comes to mind is that there might have been a problem with installation. Would you be able to try re-copying over all of Store's files to their relevant locations in EE and try again? Do you still get the same thing?
    – Ian Young
    Feb 18, 2014 at 17:29
  • @Ian I did try that, but will try it again and let you know. It could be an issue with the EE set up on the test server. Feb 18, 2014 at 21:56
  • Are you running EE Core? Feb 19, 2014 at 0:34
  • @AdrianMacneil Yes, I'm running EE CORE Feb 19, 2014 at 11:47
  • 1
    Graham, that will be why. Store provides options to integrate with member management at the point of checkout but if you're only running the Core then the Member module wont be included. You can see a table of features between Core and full version here.
    – Ian Young
    Feb 19, 2014 at 14:24

1 Answer 1

1

Per the comments - OP was running ExpressionEngine Core edition.

Expresso Store requires the full version of ExpressionEngine, as it relies on internal member management features only available in the full version.

2
  • Thank you for the information, very useful for everyone to know. Feb 20, 2014 at 12:37
  • 1
    It should probably also be noted that using EE Core for commercial purposes, as presumably a site using Store would be, is in violation of the Core license agreement. Feb 21, 2014 at 4:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.