1

Changed my Control Panel to https, but assets doesn't show images nor let me load. In http it works fine, but when i change the address to https, according to firebug, the address https://myurl.com/index.php gets redirected. I already have $config['assets_site_url'] = "/index.php"; on my config file, so what am i missing?

2

It's also worth noting that using protocol relative ( //domain.com ) will work in most situations. This allows you to not have to hardcode a protocol specific url. Helpful when you're using the same code on a live HTTPS site as well as a local, HTTP site.

1
  • 1
    This is the correct answer IMHO because you can swap between protocols with no problem.
    – tatlar
    Jan 8 '15 at 22:51
2

Just make sure your site url and all of your url paths in your admin > general configuration are https:// and also go to your content > file > file upload preferences and make sure that the url path there is https://. Also if you are hard coding the urls in your html head when attaching assets like css and js make sure those are https:// as well.

1
  • This worked for me. I added that line to the config.php file and it sorted the issue. Thanks.
    – DVLPR
    Mar 3 '14 at 18:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.