7

I've had the same problem happen a few times, on several different EE sites, but I can't determine the cause so I'm turning to y'all.

Symptom: The site's main index page will fail to load and will display a blank white page with no output. When diagnosed, the problem turns out to be that the default template group "forgot" that it was the default template group. More specifically, the "is_site_default" field in the exp_templates table, was set to 'n' for all template groups. (In order to function, it has to be set to 'y' for one template group for each site you are running.)

Has anyone had this happen to them, and if so, do you know what causes it, so I can avoid it recurring?

  • 1
    Could it have to do something with clearing cache? Didn't had this before. – Timo002 Feb 19 '14 at 22:57
  • 1
    Seems like the default template group could be set via the config file and avoid that? – Aaron Feb 21 '14 at 21:50
  • 3
    Was the template group or template removed, and then restored by syncing from files perhaps? – Derek Jones Apr 30 '14 at 20:14
  • 1
    Good thought, Derek, but no. I suppose it's a mystery. – Travis Smith Jun 5 '14 at 7:42
  • 2
    Hi Travis, could you run github.com/andrewfairlie/rc_debug and paste the output into GitHub Gist? If we know details about you're setup we might be able to crack this one... – Mutual Jun 12 '14 at 7:45
-2

If you go to Templates and then click on the Template Group that you wish to make the index template the default template and click on Edit Group for that template group then you will see a simple edit page come up which will allows you to change the Template Group Name and also there is a checkbox to enable just what you need there.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.