4

I installed Freemember as an addon module for Expression Engine. I'm still getting this error when I try to set up registration form.

Error

In order to use the encryption class requires that you set an encryption key in your config file.

I'm using EE 2.7.3 and PHP Version 5.3.2 . I have added this to my config.php file

$config['encryption_key'] = "l49YGsxdrq3VcNJdxTWQcaKKhBKREfNb7nbGSxOxBPMnHumuzCVkwa9xoTFHkBq";

So why I am getting this error message?

Thanks you, randy

  • 1
    Which version of FreeMember are you running? – Adrian Macneil Feb 21 '14 at 0:46
  • 3
    Did you find the solution to this? If so, it would be helpful to come back and post the answer for future visitors. – Adrian Macneil Mar 6 '14 at 1:19
2

Make sure it is not being overwritten in the config.php file. At the bottom of the config file, the encryption key is declared as blank, so make sure the key is entered there, or below these lines of code

/*
|--------------------------------------------------------------------------
| Encryption Key
|--------------------------------------------------------------------------
|
| If you use the Encryption class or the Sessions class with encryption
| enabled you MUST set an encryption key.  See the user guide for info.
|
*/
$config['encryption_key'] = '';

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.