1

just used Dev Demons' Updater for the first time (update 2.6.1 to 2.7.2) I got a not completed message and them the following: AJAX request failed.

However when I look at the current version running its updated. But when I go the Updater CP I see the "Ajax Request Failed" when I click on the "Show Response" link I get:

{"error":" Error Number: 1054</p>\n\n

Unknown column 'csrf_exempt' in 'field list'</p>\n\n

SELECT class, method, csrf_exempt\nFROM (exp_actions)\nWHERE action_id = '44'</p>\n\n

Filename: libraries/Actions.php</p>\n\n

Line Number: 82</p>"}

When I go to the EE CP I get this message: Your ExpressionEngine installation’s version (2.6.1) is not consistent with the reported version (2.7.3). Please update your installation of ExpressionEngine again.

enter image description here

  • In your exp_actions table, what method and class is action_id 44? – Derek Jones Aug 28 '14 at 20:56
2

Easiest solution that I've found for this in the past, is to go into your /system/expressionengine/config/config.php file and change the version number in there back to 2.6.1 and then re-run the upgrade using updater.

This would reapply the update and should resolve the problem for you.

| improve this answer | |
  • I looked at the config file it had 261 as the version. Still got the error. – seeingis Feb 25 '14 at 0:20
  • I reverted my config version back to 255 and re-ran the 2.9.2 upgrade, this fixed my issue. Thanks – Bradley Flood Oct 15 '14 at 23:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.