1

Has anyone ever seen this behavior before? I seem to have random entries missing from my site. This has been going on for a few months now and I've chalked it up to some weird anomaly when it first started happening. Now, I'm noticing that entries are missing because I'm getting crawl errors inside of Analytics and Adsense admin. I probably haven't deleted an entry in five years so something weird is going on.

0
1

This is NOT good. A couple of possibilities occur to me.

  1. Your host migrated your site to a new database server and failed to import the data correctly.

  2. Someone has exploited a vulnerability in EE1.

If you look at the EE1 Change Log there are security fixes right up until the final version (1.7.3). If you are running a version older than that there are certainly vulnerabilities. If you are 1.7.3 there are very likely vulnerabilities as the code is not longer being maintained.

I'd start by going through my server log files to look for unusual control panel access, but some vulnerabilities might not even require this.

If you have database backups I'd look at those as well to see if you can determine when the missing data disappeared.

Updating to the latest version of EE1 might help but for the longer term you must get off of EE1 for the sake of security.

2
  • My old host was EngineHosting and I had been with them for years. I'm pretty certain they didn't do any moving to a new database server while I was with them. In fact, up until I moved to a new host, they didn't want to move me to a new server for that fact that I was still using EE 1.x. I've only been on the new host for a few weeks. I'll have to see if I can access to the server log files and see if I see anything. There's not rogue member accounts setup in the Admin (just me). So, I know someone hasn't added a new Admin account or anything. I'll also see if I can update to EE 1.7.3 – deronsizemore Feb 25 '14 at 16:26
  • I'm planning on redeveloping the site with Python/Django anyway, but that won't be for a few months probably at least. That's really the reason I don't want to pay to upgrade to EE 2.0 and worry about getting addons working again and all that. – deronsizemore Feb 25 '14 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.