1

Experiencing some strangeness after deploying to Staging. I get this error when trying to access the EE CP:

Unable to initialize ExpressionEngine. The EE core does not appear to be defined in your autoload file. For more information please contact technical support.

This only happens if I try to go to:

http://stagingurl.com/ee/

Where admin.php has been renamed inside an /ee/ folder as index.php

However, strangely,

http://stagingurl.com/ee/?S=0&D=cp&C=login

Works, allows me to log in. The site also works as expected in the front-end.

I'm not sure what's going on here and how to fix? And what happened?

I also happen to be using Focus Lab's Master Config. My local install is perfectly fine as well. Help! Don't want to break the site when it's ready to deploy LIVE.

EE v2.7.2 - Build Date: 20131008

  • Permission all set correctly? Care to share the contents of your Focus Lab config.master.php file? – Natetronn Feb 25 '14 at 5:00
  • Checked permissions of all the files (config.php, database.php, cache and image folders) - it is all correct. As for config.master.php file, the one we have looks like this: gist.github.com/emilylewisdesign/fa1432afc0d8ebf436ed It's the same as the regular one, but I believe we uncommented the "is system on" to default to "y" – lealea Feb 25 '14 at 18:12
  • Not sure this will address the issue at hand though, it needs to be done either way. Change this line to fit your new CP path e.g. $env_config['cp_url'] = env_config['base_url'] . '/ee/index.php'; – Natetronn Feb 25 '14 at 22:32
  • @Natetronn Thanks for the heads up, but yeah, that didn't remove the error. So strange. O_o; – lealea Feb 26 '14 at 21:05
  • It looks like there's something going on w/ having admin.php as a sub-directory versus in the same folder as index.php. I just changed it & the query string auto appends itself w/o issues if it's stagingurl.com/admin.php – lealea Feb 27 '14 at 3:32
1

For shits and giggles, have you tried renaming to anything else as a test? yourfunname.php? Is there some sort of htaccess conflict using index?

| improve this answer | |
  • I did rename the folder to /test/ as well as renamed it back to admin.php under /ee/admin.php — it borked it even more! Like it couldn't find the proper path and then I wasn't able to log in using that where the themes would load. So I reverted back and it worked again (but with only the appending) – lealea Feb 25 '14 at 18:10
  • In googling this error I stumbled upon the file that generates it within a public Github repo, (controllers/ee.php) if seeing that info may help. Is there a known course of action regarding this kind of thing? Public shaming, etc…? – Jessica D'Amico Feb 25 '14 at 20:43
0

Same thing happened to me. A possibility is you didn't copy the config folder to the live version of your website. The routes.php file has some new code which is necessary to enter the control panel like you are used to.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.