0

I'm using Expresso-store and on the checkout page I want to update the cart with the modified quanty. But when I hit the update button, I'm redirected to the wrong page.

I'm on: http://www.myurl.com/en/cart

And I'm redirected to: http://www.myurl.com/http://www.myurl.com/en/cart

The hidden fields contain:

<input type="hidden" name="return_url" value="en/cart">
<input type="hidden" name="RET" value="http://www.myurl.com/en/cart">

I have no idea why it's redirecting wrong. The update however is done correctly!

Edit: I'm using this Publisher plugin for multi language.

Edit:

The next button is working now and redirecting correctly with the following next parameter.

{exp:store:checkout next="{publisher:current_language_code}/winkelmand/gegevens"}

Edit:

I found out that it has something to do with publisher. When I enable Add URL prefix the full URL is returned in the hidden RET field. Disabling this setting will put a relative URL in the hidden RET field.

2
  • 2
    The problem with redirection on the next page in the checkout was down to the use of {current_url} in the next parameter, setting an absolute URL rather than a relative one. The cart update button is most likely something similar or down to integration with the Publisher addon as it steps in with EE's native route handling. I'll update with an answer when resolved via support ticket. – Ian Feb 26 '14 at 10:33
  • Are you still stuck on this? It sounds like disabling the Add URL prefix option solves the problem, is that right? – Adrian Macneil Mar 6 '14 at 1:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.