1

I'm trying to filter results to a few channels and I want to exclude entries in the news channel with the category of "Internal News". The following returns no results.

{exp:super_search:results 
    channel="not blog|breakouts|calendar|work|heros" sort_by="asc"
    limit="15"
    status="open"
    category="-Internal News"
    relevance="title=500+summary=10+body=2" 
    relevance_proximity="yes"
    highlight_keywords="strong"
    smart_excerpt="yes"}
...
{/exp:super_search:results}

I've tried category="-internal-news" and I've tried the category filter in the search form with no luck.

3
  • Have you tried removing as many parameters as possible to see if that makes a difference (eg. smart_excerpt, highlight_keywords, relevance, relevance_proximity, limit)? The less parameters, the closer we are to isolating the problem. Also, sort_by="" is not a valid parameter.
    – Solspace
    Mar 14, 2014 at 6:58
  • Another note here to mention that the main poster is using Super Search 2.1.3 on EE 2.7
    – Solspace
    Mar 14, 2014 at 6:59
  • I removed everything down until it was just the category parameter and It still returns 0 results for any search term. {exp:super_search:results category="-Internal News"} Mar 14, 2014 at 13:58

1 Answer 1

1

Have you played with the category_indicator= parameter to make sure it's matching the way you are indicating your categories? I find it's always much more robust when using category url titles.

1
  • Maybe try quotes around the category name because it's multiple words? I find things can get messy if you allow spaces so it might be worth switching to category url titles instead. Mar 30, 2014 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.