0

I have installed the Expresso store_check extension locally. After enabling the extension I can see a row is created in the database in exp_extensions. A new 'Check' payment method should be shown in the Store settings but it's not there.

Now when I deploy to my dev server there's no problem, everything just works. I've tried uninstalling and disabling the extension and removed the database entry numerous times without succes. What else can I try to get this to work?

2
  • Does the check extension show up in the extensions list under the add-ons menu? Feb 28, 2014 at 16:46
  • Yes, I can enable and disable it without issues.
    – Bob H
    Feb 28, 2014 at 18:58

1 Answer 1

1

There isn't really enough information in your question to diagnose what might be wrong, but if it's working fine in your development environment, then the only explanation is a difference between your development and production environments.

This might sound silly, but the first thing I would check is that your production website does in fact have the extension uploaded correctly, and that database does in fact have the extension enabled (and that you don't have your production website talking to your test database or vice versa).

2
  • I develop locally, git commit my changes, deploy to my dev server and then import/export my database. I don't see how there can there be differences? I did manually double check if the files and the database records are all there and they are.
    – Bob H
    Mar 6, 2014 at 11:56
  • After all this I also tried a reversed approach: I installed and enabled a few clones of the store_check extension on my dev site, tested them on the frontend to confirm they all worked. I then copied the files to my local install and migrated the database. The results are even stranger: only 1 of the clones is listed on the payment methods page and another unrelated method I'm using has disappeared. It's a mess.
    – Bob H
    Mar 6, 2014 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.