2

I just upgraded to EE 2.8. I know it's brand new, but I'm already having an issue that I can't seem to fix.

On the publish page, and when adding a field to a field group, I see the following error in the developer log:

"Uncaught TypeError: Object 132 has no method 'replace'"

JS features don't seem to work on the publish pages, and when I try to add a custom field to a field group, I can't customize any fields. No matther which field I choose, I just get the name and description options, but no ability to customize the actual field properties. For instance, if I choose relationship field type, I don't get the ability to customize the relationship settings. It just doesn't even show up.

I'm wondering if an installed module is conflicting, but I'm not quite sure how to find it. Anyone else having an issue with 2.8 like this?

3

The error has been confirmed as a bug in EE 2.8.

Bug tracker: https://support.ellislab.com/bugs/detail/20165

The issue will be fixed in the next release, and a patch has been posted to the bug tracker for any who need it.

| improve this answer | |
  • As an update to my update, it appears that this fixed this issue with Wygwam, but not Playa. Bug tracker is updated, still waiting for more info. – Jeremy Gimbel Mar 4 '14 at 16:11
3

For my specific case, it appears to be addons such as Matrix and Assets by Pixel & Tonic that are causing this. By uninstalling the addons I was able to get rid of this error.

| improve this answer | |
  • thanks, I will wait a little bit before to upgrade to EE 2.8 – Stéphane Mar 1 '14 at 23:56
  • Just FYI, Assets by P&T is also causing this. They are aware and are looking into it. I didn't test any of the other P&T addons, but they are aware and they are looking into it. – jthomas Mar 2 '14 at 2:41
  • When many addons are installed, it can give headache to find what is the problem. The new features of EE 2.8 sounds very nice, it would be frustrating not implementing them yet in your project. – Stéphane Mar 2 '14 at 12:29
  • Thanks for the update. I'm experiencing the same thing and eagerly await updated addons from P&T. – Jeremy Gimbel Mar 3 '14 at 2:25
  • Just an update. P&T tracked this down to a JS error in EE 2.8 and have submitted a bug report. – jthomas Mar 3 '14 at 18:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.