I've just updated EE from 2.5.3 to 2.7.3 and gone from a local testing environment (using Focus Lab Master Config) to a remote server. All works great apart from in my search results (using Low Search). If I click past the second pagination link, the link starts with my local test domain!!! WTF?!

I've done a DB dump and tried to grep to find any instances of this local address and the only thing I see is in the developer logs.

Has anyone ever come across anything like this?

I've cleared the contents of my ee cache directory as well. No joy.

  • Can you add a bit more info? Like, are you encoding the search query or using GET vars? What's your LS version? Can you add the Results tag code here?
    – Low
    Commented Mar 4, 2014 at 13:37
  • I'm having this exact same problem except with Structure. On my staging environment, when I click "View Page" on structure pages, it takes me to my local dev url. What is going on?!?! expressionengine.stackexchange.com/questions/20343/…
    – jthomas
    Commented Mar 16, 2014 at 0:57

3 Answers 3


So thanks to Low stepping in and doing some testing with me, we worked out that the problem was down to an extension hook for Structure that was messing up ALL pagination across the site.

Low performed the following sql query to find the hook in question:

SELECT * FROM exp_extensions WHERE hook = 'channel_module_create_pagination'

and then removed the Structure hook with the following query:

UPDATE exp_extensions SET enabled = 'n' WHERE extension_id = 148;

Note that in my particular case the Structure related extension_id was 148 - yours will no doubt be different (should anyone else come across this).

Now that is removed, all appears to be working as expected again.

  • Hmmm, I suppose I will give this a try. I wonder if it's the same thing causing my issue with Structure's "View Page" link loading my dev url even though I'm on staging.
    – jthomas
    Commented Mar 16, 2014 at 0:59
  • Does this not then prevent Structure from working as expected? Exact same issue here... Commented Apr 15, 2014 at 21:44
  • I'm not having any issues with Structure to be honest. It's behaving itself despite that change. Commented Apr 29, 2014 at 9:24

Try completing the Comment Page URL fields in Channel Preferences. It's what Low Search uses for auto paths to multiple channels. Then double check it's not being overridden in FLMC.

  • Hi James. This is a single channel search issue. I'm adding the domain in Channel Prefs anyway. What's FLMC? Commented Mar 4, 2014 at 13:33
  • Focus Lab Master Config == FLMC Commented Mar 4, 2014 at 13:34
  • Thanks guys - tried the channel prefs thing - nothing. Also I've search my entire file system for "pp.dev" (my local env) and there's nothing. No clue where it can be coming from. Commented Mar 4, 2014 at 13:36

It sounds like your local domain pp.dev has been saved in the database as the site url and it's either not being overridden properly by your config or LS is using the db version.

  • Thanks exactly what I thought Jamie. I did a db dump and used grep to see if I could see any instances of pp.dev. Nothing at all. Commented Mar 4, 2014 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.