1

Using Freeform (free version) for two forms on my site. Both forms send a message to admin as well as a confirmation back to the sender.

I have Postmaster setup to send all system emails, so all Freeform notifications are routed through Postmaster to be sent (through Mandrill, not EE).

I get strange results in my email sent emails like this:

This is a multi-part message in MIME format. Your email application may not support this format. --B_ALT_53168daed37f9 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 8bit

Followed by a text only version of the email, and then...

--B_ALT_53168daed37f9 Content-Type: text/html; charset=utf-8 Content-Transfer-Encoding: quoted-printable = =20

My HTML version of the email is also slightly disfigured and loses its CSS styling.

The issue appears to be that Freeform is sending a multi-part message and headers which is then being embedded inside the Postmaster email template (which is HTML). Even if I make the Postmaster template blank and include all the HTML in the Freeform template, I still get the same problem.

The only way around this issue that I can see is to force Freeform to not send a multi-part message (and no headers) so they don't double-up or conflict with what Postmaster sends out. Is this possible?

If not, how else can I make Freeform compatible with Postmaster? If I can't resolve this there's no way I can use Postmaster to send me system emails.

Just wanted to note that this is specifically a Freeform & Postmaster issue. All other system emails send out fine with this setup so it must be due to the way Postmaster formats the email.

  • "Your email application may not support this format." sounds like a good hint. Did you try another email address and/or email application? Did you try sending HTML email through the native EE Communicate tool? – Solspace Mar 5 '14 at 6:44
  • I've discovered a bit more about this problem and I suspect it has nothing to do with my email application. I'm using Postmaster and have set it up to send EE system emails through Postmaster. But I think Postmaster has also hijacked the Freeform emails and it's passing them through my Postmaster hook templates which is causing the problems. I'll have to remove the Postmasker hook to confirm if it works properly without it. – Benek Lisefski Mar 5 '14 at 7:21
  • So it looks like what is happening is that Freeform sends a multi-part message which is then embedded into the HTML wrapper of the Postmaster hook. So the plain-text version and the HTML version are both being injected inside the HTML wrapper, and that's what's causing the mimetype error (I think). So @Solspace is there a way to disable Freeform from sending a multi-part message and send only the HTML version instead? I think that may clear up the problem. – Benek Lisefski Mar 5 '14 at 21:34
  • I've edited the original post to clarify the situation as much as possible based on my best understanding of what's going on after some more tests. Would really appreciate some help here if possible. – Benek Lisefski Mar 6 '14 at 20:44
  • Honestly we are not sending specific mime headers with emails in Freeform. We are using EE/CI's built in email class, which does all of the lifting. The only settings we set are wordwrap, html, and then the Tos, message, and subject. This sounds more like it might be a Codeigniter issue: stackoverflow.com/questions/18283661/… – Solspace Mar 7 '14 at 23:31
3
+50

It turns out the answer is to turn off "Allow HTML" for all Freeform notification templates. I believe this is because Freeform will then leave the email as plain text allowing Postmaster to encapsulate it as HTML.

Benek, I'm glad it's all sorted for you! :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.