2

I'm using EE 2.7.3 and I'm getting the following error when trying to create or edit a field: Unable to load the requested file: col_settings_tmpl.php . It seems to be related to the grid field type, disabling it as suggested elsewhere is not really an option as it's used throughout the site.

The site works correctly when I set it up locally, but I get the above error when I move it to the live server.

Thanks,

  • Did you figure this out.. I have the same issue. Works fine on my local MAMP server but i get this error on hosted servers, from Siteground and 34sp. Looked into this and followed the error to, for me, the Structure Field type disabling this field type, just the field type solved the issue. The function add_package_path( ) in sql.structure.php causes the issue for Grid. Hope this helps someone. _S – user2840 Mar 12 '14 at 16:04
  • Hi There, no fix yet I'm afraid. I hoping someone can come up with a solution as it's starting to become an issue. It seems to be related to the grid field type, but removing it is not really an option as it's used heavily throughout the site. – Mark Mar 13 '14 at 9:41
  • Did you ever fix this? I'm using 2.8.1 and getting this error when trying to edit or add custom fields. Strange thing is.. I built the site fine and its suddenly started throwing this error. – Mark Jun 24 '14 at 6:33
  • Hi Mark, sorry no, I never got a fix for this. – Mark Jun 30 '14 at 16:38
  • 1
    I'm getting this in 2.8.1. According to EllisLab, it's related to third-party add-ons (ellislab.com/forums/viewthread/237629). Uninstalling the Grid fieldtype worked for me. – Andrea DeMers Aug 7 '14 at 18:33
2

I had this problem just now.

For me.. it was due to a duplicate of a third party module left over from when i updated.

Basically i was updating low variables and duplicated the exisitng files just as a safety net... so i had a folder called 'low_variables - copy'

Once i removed that everything worked as normal.

| improve this answer | |
0

I have debugged the code of the file "admin or system\codeigniter\system\core\Loader.php" and found that one backup of the folder of the forms addon in the third-party addon so I have removed it and now working fine.

How can we found it?

We need to print_r the "$this->_ci_view_paths" this variable in "admin or system\codeigniter\system\core\Loader.php" file and found that return array of the paths and there is some file path as key have not value as "1" for that path that means that folder path is duplicated or it has some issue. so remove that folder and try again. enter image description here

enter image description here

Second solution for after upgraded to EE 2.11.1

After upgrading 2.11.1 to 2.11.9 then I have faced the same error again. So I have debugged again. Print the path and array according the below screenshot in the Loader.php fileenter image description here

enter image description here

Here, you can see the col_settings_tmpl.php file is trying to getting form the system or admin/expressionengine/views folder so something is wrong because this path have not that type of file. so I have tried to clear cache but no luck.

Then temporary, I have comment the show_error function line as per the blow screenshot and everything is fine. But I know that this is the not proper way by using that I know this path related setting is not necessary for the edit field setting page.enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.