0

When I open Add Ons > Modules > DataGrab I get the following PHP Errors:

enter image description here

I am running EE 2.7.3 and DataGrab 1.8.0. Any ideas what is happening here?

Thanks.

3
  • That error seems to say that some of your plugins are installed twice. Are they? Or at the very least some plugin has overlapping namespace with the Magpie plugin. Perhaps Datagrab is not compatible with the Magpie plugin to the extent that they both load variables with the same names. If the Magpie plugin is not mission critical try moving out of the plugins directory and see if the problem goes away. – AllInOne Mar 10 '14 at 19:49
  • I removed the magpie plugin and the errors go away, so you are on to something here. I'll contact the developer and see what I can figure out from him. Thanks. – forrest Mar 11 '14 at 15:59
  • Magpie RSS parser is a PHP library. magpierss.sourceforge.net My guess is that both add-ins incorporate it and there is a namespace collision. – AllInOne Mar 11 '14 at 18:46
1

Recasting my comments as an "Answer":

I would guess both DataGrab and Magpie.pi incorporate the Magpie RSS processor written in PHP

That's fine. What isn't fine is that both add-ons are defining variables/classes with the same name.

I'd check to see if you are running the latest version of both of these add-ins as it may be something that one or other developer has encountered and fixed previously.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.